Jump to content

Welcome to GamingIO - Gaming should be fun and free(dom)
Register now to gain access to all of our features. Once registered and logged in, you will be able to create topics, post replies to existing threads, give reputation to your fellow members, get your own private messenger, post status updates, manage your profile and so much more. If you already have an account, login here - otherwise create an account for free today!

Samsung EVO 850 SSD 1 Terrabyte


  • Please log in to reply
1 reply to this topic




  • Administrators
  • 208 posts

Attached File  Samsung ssd.JPG   39.67KB   0 downloads


OK, I finally caved in and bought an SSD. A Samsung EVO 850 1 TB. I am using Windows 8.1 with a total of 7.5 TB disks attached to every hole a desktop can have before adding the SSD.



Everything went smoothly from connecting it to using the migration software to transfer my 2 partitions from 2TB SATA IDE disk to the new SSD. Total data was about 750GB which includes all my steam and origin games. It took about 2 hours because I did no cleanup or changes to the disk, just as is. It could have been faster had I done some cleanup. Neverthless, there is other stuff to do. The software copied my boot and EFI partitions as well. 


The reason I copied the Windows partition as well is because the Samsung software gives no option to "deselect it" , Samsung is known for failing at great software ideas. I did not plan to use the SSD for Windows. So anyway....


This is where thing went to shit.


Problem started when I tried to boot of the disk. The UEFI detected the drive but always booted the original disk. So like any experienced techie I googled for this stuff, And, it did not help. Apparently the system will use Disk0 to boot as per forum posts so I unplugged the DISK0 which was my original drive. and even attached the SSD to it. This time the BIOS does not even see the disk , which was coincidently the responses in another forum posts. I realized that the entire forum activity revolved around some members selling some software to other newbs. Namely Macrium and "whateverIforgot". Makes no sense to fork out for a one time use software.


The Windows UEFI was visible which is I suppose part and parcel of the new generation of BIOS but no disks were showing. Nothing is loose because once I put the original disk back in position it all worked great. Screwing around with UEFI and BIOS only wasted another hour on a new years eve.


"Fk this", I said to myself but loud enough for everyone else to hear. I finally kept my original drive as Windows partition. I swapped the partition on the games partition drive letter over to SSD. I have a habit of partitioning stuff , I did not remember why I do this but seems to have been a good idea. Then I deleted the windows partition on the SSD and since I had no more patience and really wanted to play Battlefield 4 without delay I chose to make the Games partition "Dynamic" which makes a lot of SSD optimizations impossible. The Dynamic partition allowed me to extend the Games Partition to include the extra space. Good enough....for now.



Problems I have had that could be related to Windows not detecting the SSD as SSD. 

Copying lots of small files causes errors and gets stuck occasionally on certain files. 

When I tried copying over the same files it seems those files were NOT copied earlier so I did not get prompt for overwrite. 

This was solved by disabling "Write Caching" which I suspected was the issue. Right click the drive and look for "Advanced" stuff, it's there somewhere. Again, Samsung "Magician" software bundled for this would not work because it assumes your Windows itself is on the disk so it tries to disable pagefiles on Windows, avoid it. It slows down reboot. 

Copying files as large as 4GB is almost instant as it does not require Write caching, straight to disk and quite fast (3-4 seconds), only limited by read speed of the source disk. 

Downloads are now coming through to disk at 500Mbps++



Damage SG$ 715 and 4 hours inclusive of disk swapping, rebooting, googling, swearing.....

                  I still do not know why my windows partition is using 300GB wtf!



I will have to read up on UEFI and EFI stuff before attempting to waste another day as it has been years since I hacked BIOS to replace my POST screen image. Any ideas are most appreciated. 



Next stage: if I want to use the entire SSD for windows as well.

Since I am using the SSD now and the state of the machine has changed, I believe a windows reinstall is possible using restore point, I have more than enough space for it. However i'd need to restore the Games/Data partition as well. I dont believe 32GB of RAM is going to make one heck of a difference in how much time THAT is going to take.



  • DragosHig, ClifqtonShili, Rodneycrymn and 2 others like this




  • Administrators
  • 208 posts

Drive test results. Note VM overhead might exist but system is not busy.


hdparm -t /dev/sda5

Timing buffered disk reads: 1126 MB in  3.00 seconds = 375.16 MB/sec



This is the Enteprise SSD on Linode servers test results. This isn't a Samsung EVO for sure :P

Note: System is extremely busy with multiple read/write operations. This theoretically does not affect SSD. 

/sbin/hdparm -t /dev/xvda

Timing buffered disk reads:  2020 MB in  3.00 seconds = 673.11 MB/sec




What does a regular drive look like (Enterprise SATA HDD). The system is very low busy on IO. However this is a raid 5 disk so it may not be performing best. However it is not far from actual reading on an idle disk with no raid. 

hdparm -t /dev/md2

Timing buffered disk reads: 362 MB in  3.01 seconds = 120.32 MB/sec




I haven't performed any write tests

Also tagged with one or more of these keywords: Help